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Why Doesn't the Translation Interface Toolbar Display?

The following article applies to Global Delivery Network, Application Resource Files, Business Documents, and CMS Connector project types. 

Symptoms

When attempting to view a page in Edit mode, the Translation Interface (TI) toolbar does not display and inline editing is unavailable.

Cause

Smartling requires the following formatting of HTML source code on the page to correctly parse and display the Translation Interface:

  • An opening <html> tag
  • A <head> tag
  • <body> tags
    Some frameset pages, where the web page is split into several segments, do not have <body> tags; such pages presuppose no <body> tag ever and the toolbar cannot load on the page.
  • Opening and closing tags for block and inline element

Tags that are not closed or closing tags with no corresponding open tags, or the improper nesting of elements are especially problematic.

Workaround

For frameset pages, you can load the frame page (by determining the URL), and the TI should work.

 

Solution

Try checking your source HTML against an online validator such as http://validator.w3.org.

This article was last updated on October 7, 2013.

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